Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2026 - 08:00 BST
Scheduled
We'll be carrying out essential network maintenance on Saturday 30th May from 8:00 AM to 5:00 PM. During this time, Dotpost will be unavailable. Thank you for your patience.
Posted May 12, 2026 - 16:05 BST
This scheduled maintenance affected: Dotpost, Document Delivery, Email notifications, and Documents.