Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 21, 2024 - 06:00 GMT
Scheduled
We are moving to a new Customer Support platform. During this time dotpost@cfh.com will be unavailable. Any emails you send to us may not be received, If this happens you will get an error message from your email platform. Please resend at a later time.
Posted Nov 15, 2024 - 15:11 GMT
This scheduled maintenance affects: Email notifications.